tw5 not firing

All the information that is relevant to new MP5 goes in here.

tw5 not firing

Postby scuba-phil on Mon Oct 12, 2015 11:27 am

bought a tw5 used and put a couple mags through it, in between mags having issues of not firing. So using the cocking handle, going back to safe and taking the mags out and re inserting got it going again.
I was later informed the gun has a mod that bypassed the cocking handle.
Now the gun wont fire at all

What is the likely cause here, i don't want to change the bolt stop board for the sake of it as that is what im thinking could be the cause
scuba-phil
Newbie
 
Posts: 34
Joined: Sun Aug 01, 2010 5:02 pm
Location: Chester, UK

Re: tw5 not firing

Postby thundercactus on Mon Oct 12, 2015 4:36 pm

A lot of times on the TW5, the selector drum can misalign itself.
Unfortunately for everyone, the TW5 is built like crap, and it breaks down in stupid ways.
You should probably take it to an experienced tech so they can properly diagnose the problem.
thundercactus
Expert
 
Posts: 437
Joined: Thu Dec 27, 2012 8:04 pm
Location: Calgary, Ab, Canada

Re: tw5 not firing

Postby CxK-ArthurDent on Mon Oct 12, 2015 6:39 pm

:idea:
the TW5 does not have a "working" cocking handle, so there is no way to bypass it.
just for your info ..

the bolt stop board is not the problem too, cause the TW will work even when this
board is not installed.

a real PTW would disengage the the boltstop to stop when a mag is empty
the TW engages the boltstop when the mag is emty - so it works even when you brake off
the long switch.

the electronics work as with a ptw - if you have an error (red blinking LED with a PTW) you have to
switch to "save" to restet the failure.

if your gun works for some mags, stops and never works again - i'll bet it's the motor / brushes
that causes this.

- on the other side it could be the selector drum, cause they are prone to brake internaly.
but first - check the motor.

the TW not really crap "inside" - it's just an AEG, but a very cool and heavy one ..
visit us: --> www.CxK-rl.com
User avatar
CxK-ArthurDent
Groupie
 
Posts: 202
Joined: Wed Oct 10, 2012 2:28 pm
Location: Germany

Re: tw5 not firing

Postby scuba-phil on Mon Oct 12, 2015 7:22 pm

How do you test the motor? Is it a case of removing it and giving it current?
scuba-phil
Newbie
 
Posts: 34
Joined: Sun Aug 01, 2010 5:02 pm
Location: Chester, UK

Re: tw5 not firing

Postby CxK-ArthurDent on Tue Oct 13, 2015 2:54 pm

visit us: --> www.CxK-rl.com
User avatar
CxK-ArthurDent
Groupie
 
Posts: 202
Joined: Wed Oct 10, 2012 2:28 pm
Location: Germany


Return to Generation MP5 (2008)



Who is online

Users browsing this forum: No registered users and 1 guest